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Если, конечно, не ошибаются наши коллеги-журналистки, пишущие
о современной моде, то одной из ее ведущих тенденций сейчас яв-
ляются… карманы. Да, да, именно они. Аналогом таких карманов в
компьютерном мире можно назвать Буфер обмена. И программисты
периодически обращаются к этой «детали туалета», пытаясь сде-
лать ее более функциональной и удобной.

О б з о р  с l i p b o a r d - м е н е д ж е р о в

Одной из самых больших модниц

традиционно считается операцион-

ная система Windows. И действи-

тельно, хотим мы этого или нет, но многие

тенденции, разработанные под нее, были

новаторскими для своего времени и лишь

позднее подхватывались конкурентами. Тем

удивительнее невнимание «кутюрье» от

Microsoft к «карману» своей модели — Бу-

феру обмена. Одна версия их системы сме-

няла другую, а Буфер обмена как был один-

одинешенек, так единственным и оставал-

ся. В Word 2000 и Word XP, правда, добавили

к нему еще несколько отделений, но только

для его собственных нужд. «Карман» самой

Windows все равно оставался без измене-

ний. По-прежнему одно отделение, которое,

в принципе, еще можно просмотреть. И

все… и больше ничего.

Те, кто работают с текстом, да и с графи-

кой, знают, что одного Буфера обмена

очень часто бывает недостаточно. Так что
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»

Карман — мешочек,  пришитый к  одежде 
или на поясе…

Толковый словарь Владимира Даля
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волей-неволей приходится пользователям

Windows обращаться за помощью к сто-

ронним разработчикам за утилитами,

расширяющими возможности системного

«кармана». Их обычно называют сlipboard-

менеджерами.

В сущности, все они выполняют одну и

ту же задачу временного копирования в от-

дельную папку текста и графики или только

текста, угодившего в Буфер обмена. Отли-

чий между ними совсем немного: во-пер-

вых, в количестве этих самых «карманов», а

во-вторых, в удобстве их использования и

дополнительных функциях. И, наконец, в

том, что одни разработчики сlipboard-мене-

джеров хотят получить за свой труд шелес-

тящие купюры, а другие обходятся исклю-

чительно моральной поддержкой. Но так

или иначе, а выбрать каждому конкретному

пользователю вне зависимости от его дохо-

дов есть из чего.

Настоящий обзор, как я надеюсь, смо-

жет помочь вам в определении «последне-

го героя» Буфера обмена. Само собой разу-

меется, что все программы-менеджеры

тестировались на одной машине и условия

соревнования были созданы для конкур-

сантов равные.

В «профессиональном» классе условно-

бесплатных программ, обрабатывающих

«карман» Windows, давно и безраздельно

царствует ClipMate. На «любительском»

уровне freeware нет равных Yankee Clipper.

Лучшим российским компьютерным игро-

ком на «карманном» поле по праву являет-

ся WinClip.

Кроме того, из числа претендентов сразу

же выпали все сlipboard-менеджеры, сохра-

няющие в своем чреве только текстовые ку-

ски, в виду их неконкурентоспособности.

Ныне все большее число компьютерных

пользователей так или иначе работают с

графикой, и закрывать на этот очевидный

факт глаза уже просто неприлично.

Напоследок не могу не упомянуть о двух,

несомненно, полезных утилитах, которые

также могут облегчить работу с Буфером

обмена. Во-первых, об утилите Easy Clip 1.0

(http://www.flashpeak.com) производства

фирмы Flashpeak. Эта маленькая программ-

ка не только сохраняет для мгновенной

(или накопительной), по двойному щелчку,

вставке 16 текстовых блоков, но и предла-

гает пользователю воспользоваться мо-

бильной панелью для быстрого запуска раз-

личных приложений Windows. 

А во-вторых, обращаю ваше внимание еще

на одну российскую разработку — Book Re-

ader (http://kmc.ru/ts), озвучивающую (при

наличии, понятно, необходимых библиотек

и голосовых движков) текст, скопирован-

ный в Буфер обмена.

Александр Евдокимов

Вообще-то, название этой программы пра-

вильно переводится, как «Янки-цирюльник

III». Из чего нетрудно догадаться, что кто-

то из разработчиков Yankee Clipper, видимо,

происходит из рода потомственных брадоб-

реев. Непонятно тут другое: какое отноше-

ние уважаемая профессия парикмахера мо-

жет иметь к программе, отвечающей за

Буфер обмена Windows? Не рассовывают

же американские цирюльники по карманам

все, что настригли или сбрили у клиентов.

Может, оно и к лучшему, что потомок

брадобреев не пошел по стопам своих пред-

ков, а занялся программированием. И в

этом преуспел. Хотя бесплатный Yankee Clip-

per и не обыграл своего высокооплачивае-

мого соотечественника ClipMate по всем

статьям, но по некоторым из них превзошел

точно. Во-первых, Yankee Clipper легче и мо-

бильнее своего визави, во-вторых, он умело

распознает графику (Pictures) и текст (Text),

сохраняя их в разных коллекциях. Мало то-

го, сами текстовые фрагменты подразделя-

ются на собственно текст (Rich Text) и ги-

перссылки (URLs). И тоже автоматически…

Словом, довольно сообразительный полу-

чился «Цирюльник». Не Фигаро Бомарше,

конечно, но с отличными задатками.

Оригинальная возможность Yankee Clip-

per — вставка элемента, не находящегося

во главе списка, через 5 секунд паузы по

команде «Shoot» («Tools -> Shoot»). Только

требуемое время задержки нужно выдер-

живать точно, иначе в текстовый редактор

«Цирюльник» добавит выбранный элемент

дважды. К сожалению, вставляемые в доку-

менты данные нельзя «склеивать».

Как и у ClipMate, в этой программе преду-

смотрено два режима хранения данных —

временный History («История») и постоян-

ный Boilerplates («Формы»). Переброска

элементов во второй режим осуществляется

с помощью команды контекстного меню

мыши «Send to Boilerplates». Активизация в

нем — двойной щелчок по нужному пункту.

Количество хранящихся в Boilerplates тексто-

вых фрагментов и картинок ограничено толь-

ко вашими потребностями. В режиме же His-

tory одновременно можно хранить не более

200 элементов. Тем не менее для большин-

ства пользователей этого будет вполне до-

статочно. А значит, Yankee Clipper может

стать оптимальным выбором и для офисно-

го, и для домашнего компьютерного «карма-

на». Кстати, через меню основных настроек

(«Edit -> Configuration -> General») облада-

телям мощных современных машин есть

смысл внести этот сlipboard-менеджер в

число автоматически запускаемых Windows-

приложений.

В комплекте с программой вы получаете

еще электронный календарь, причем одно-

временно на текущий, предшествующий и

последующий месяцы, а также возможность

запуска из системного трея скринсейвера.

Yankee Clipper III

ê‡Á‡·ÓÚ˜ËÍ 3 Joe LeVasseur, Konrad Krupa

ë‡ÈÚ ‡Á‡·ÓÚ˜ËÍ‡ 3 www.yankee-clipper.net

éÔÂ‡ˆËÓÌÌ‡fl ÒËÒÚÂÏ‡ 3 Windows

ìÒÎÓ‚Ëfl ‡ÒÔÓÒÚ‡ÌÂÌËfl 3 freeware

èãûëõ/åàçìëõ

+ ‡Á‰ÂÎÂÌËÂ ÍÓÔËÛÂÏÓÈ „‡ÙËÍË Ë ÚÂÍÒÚ‡

+ ÒÍÓÓÒÚ¸ Ë Ì‡„Îfl‰ÌÓÒÚ¸ ‡·ÓÚ˚

+ ·ÂÒÔÎ‡ÚÌÓÒÚ¸ ÔÓ„‡ÏÏ˚

– ÌÂÚ ‚ÓÁÏÓÊÌÓÒÚË ÒÓÂ‰ËÌÂÌËfl ‰‡ÌÌ˚ı, 

Ó„‡ÌË˜ÂÌ ÂÊËÏ History

Yankee Clipper III

»



Российский участник соревнования по мо-

дернизации «кармана» Windows — Cood

Clip — не столь удобен в использовании,

как вышеупомянутые программы. Пользова-

тель не видит картинку, которую вставляет,

да и текст обозначен лишь схематически,

первыми словами. Правда, двойным щелч-

ком по иконке в трее можно запустить

окошко предварительного просмотра, но

при больших массивах информации такой

способ жутко тормозит работу даже при-

знанных спринтеров работы с компьютер-

ной мышкой.

Но есть функция у Cood Clip, которая ис-

купает все ее грехи, — это поддержка ло-

кальной сети. Кнопки «Предоставить» и

«Взять» позволят работать членам вашей

творческой группы сообща. Вот это по-рус-

ски! Широким жестом вы можете открыть

доступ к своему «карману» всем желающим

или только избранным. А они в свою оче-

редь могут разрешить вам немного поша-

рить в их Буфере обмена. Мы попробовали

у себя, в редакции Chip, — передача содер-

жимого «кармана» одного компьютера на

другой прошла без сучка и задоринки. Но

это все в полной версии Cood Clip, облег-

ченный вариант Lite подобного панибратст-

ва не признает. 

Русский сlipboard-менеджер позволяет

запомнить 200 элементов в стеке, важней-

шие из которых рекомендуется записать на-

долго в отдельный раздел («Добавить ста-

тический») или даже в специальный файл

(«Сохранить как»). Оригинальная «фишка»

программы — использование в списке эле-

ментов иконок тех программ, откуда они

были скопированы. Перед началом инстал-

ляции программы вам предложат выбрать,

краткую или полную версию программы

следует устанавливать. Недостатков у демо-

версии немного: появляющееся при запуске

окошко с напоминанием об отсутствии ре-

гистрации и ограничения при работе в ло-

кальной сети.
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Cood Clip 2.10
èãûëõ/åàçìëõ

+ ‡·ÓÚ‡ ‚ ÎÓÍ‡Î¸ÌÓÈ ÒÂÚË

+ Ó·ÓÁÌ‡˜ÂÌËÂ ˝ÎÂÏÂÌÚÓ‚ ËÍÓÌÍ‡ÏË ÔÓ„‡ÏÏ,

ÓÚÍÛ‰‡ ÓÌË ·˚ÎË ÒÍÓÔËÓ‚‡Ì˚

+ ÌÂÁÌ‡˜ËÚÂÎ¸Ì˚Â Ó„‡ÌË˜ÂÌËfl ‚ ‰ÂÏÓ-‚ÂÒËË

– ÌÂÛ‰Ó·Ì˚È ÔÓÒÏÓÚ „‡ÙËÍË Ë ÚÂÍÒÚ‡

Cood Clip 2.10

ê‡Á‡·ÓÚ˜ËÍ 3 DeeP125&ÑÏËÚËÈ ãÛÊÂˆÍËÈ

ë‡ÈÚ ‡Á‡·ÓÚ˜ËÍ‡ 3 www.aha.ru/~deep125

éÔÂ‡ˆËÓÌÌ‡fl ÒËÒÚÂÏ‡ 3 Windows

ìÒÎÓ‚Ëfl ‡ÒÔÓÒÚ‡ÌÂÌËfl 3 shareware

ñÂÌ‡ 3 $9

Одна из старейших отечественных разрабо-

ток в области «карманостроительства», про-

грамма WinClip от Paralaxis Software, про-

должает свою победоносную поступь по

просторам некогда нерушимого Союза. Де-

ло в том, что нам, не слишком богатым

гражданам бывшего СССР, этот сlipboard-ме-

неджер обойдется всего в какой-то $0

(ноль долларов). Если в качестве регио-

нальных настроек на вашей машине стоит

«Русский язык» и «Россия» соответственно,

то WinClip автоматически зарегистрирует

себя на имя пользователя «Russian Edition»

из одноименной компании. 

Главная отличительная особенность Win-

Clip — это приятный, радующий глаз интер-

фейс в стиле архиватора WinRar. Названия

у них тоже, кстати, очень похожие. 

Основной принцип работы этого сlipbo-

ard-менеджера — использование так на-

зываемых банков информации. По умолча-

нию — это My texts (тексты), My addresses

(интернет-ссылки) и My pictures (картинки).

Но можно создать и свои разделы («Банки ->

Создать локальный банк») или импортиро-

вать сохраненные («Файл -> Импорт бан-

ков»). Коллекции, между прочим, позволено

также сохранять («Файл -> Экспорт бан-

ков») или делать доступными в локальной

сети («Банки -> Создать сетевой банк»).

Банк AutoCopy — это, в сущности, тот же

многоярусный «карман», что и в других

сlipboard-менеджерах. Но в отличие от них,

автономный от основного Буфера обмена

Windows. По умолчанию в нем может нахо-

диться не более десяти единиц хранения,

но это количество легко увеличить до 40 в

меню «Настройки -> Advanced». Двойным

щелчком по требуемому элементу вы подго-

тавливаете его для подстановки в документ,

то есть переводите непосредственно в Бу-

фер обмена. Сохранение материалов в по-

стоянных банках осуществляется копирова-

нием информации в них («Буферы -> Ско-

пировать/Вставить»). 

Отдельной вкладкой основного окна

WinClip является «Персональная карта», за-

полнив которую вы сможете быстрее

оформлять анкеты и резюме в Интернете.

К сожалению, бесплатный русский вари-

ант WinClip имеет только английский файл

помощи и несколько англоязычных назва-

ний меню. Тем не менее она оптимальна

для русскоязычного пользователя.

WinClip 2.8 Pro
èãûëõ/åàçìëõ

+ ·ÂÒÔÎ‡ÚÌ‡ ‰Îfl „‡Ê‰‡Ì ·˚‚¯Â„Ó ëëëê

+ ËÏÂÂÚÒfl Û‰Ó·Ì‡fl ‚ÍÎ‡‰Í‡ «èÂÒÓÌ‡Î¸Ì‡fl

Í‡Ú‡»

+ Í‡ÒË‚˚È, Ì‡„Îfl‰Ì˚È ËÌÚÂÙÂÈÒ

– ÓÚÒÛÚÒÚ‚ËÂ ÛÒÒÍÓflÁ˚˜ÌÓÈ ÒÔ‡‚ÍË

– ‚ÓÁÏÓÊÌÓÒÚ¸ Ó‰ÌÓ‚ÂÏÂÌÌÓ ı‡ÌËÚ¸ ÚÓÎ¸ÍÓ 

40 ˝ÎÂÏÂÌÚÓ‚

WinClip 2.8 Pro

ê‡Á‡·ÓÚ˜ËÍ 3 Paralaxis Software

ë‡ÈÚ ‡Á‡·ÓÚ˜ËÍ‡ 3 www.pxcompany.com/rus

éÔÂ‡ˆËÓÌÌ‡fl ÒËÒÚÂÏ‡ 3 Windows

ìÒÎÓ‚Ëfl ‡ÒÔÓÒÚ‡ÌÂÌËfl 3 freeware ‰Îfl
„‡Ê‰‡Ì ·˚‚¯Â„Ó ëëëê
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О таких программах в народе говорят: про-

стенькая, но со вкусом. Как и полагается луч-

шим сlipboard-менеджерам, Clip Plus занима-

ется не только текстовыми фрагментами, но и

графикой. Все сохраненные материалы пред-

ставлены в виде списка файлов с информа-

цией об их размере, а также дате и времени

копирования. К сожалению, текстовые эле-

менты не отделены от графических, поэтому

в поисках той или иной картинки все время

приходилось бродить по списку или заранее

придумывать для нее какое-нибудь специфи-

ческое название («Clip -> Rename»).

Зато в Clip Plus удобен просмотр элемен-

тов: выбрав мышкой любой из них в списке,

в правой части окна программы вы сразу

же увидите его содержимое. Кроме того, в

программе зачем-то имеется еще и отдель-

ный Clipboard Viewer («View -> Clipboard Vi-

ewer»). Кстати, любой элемент из сохранен-

ного списка можно легко активизировать

(«Clip -> Activate») или распечатать («File ->

Print»), а при желании даже отправить по

электронной почте («File -> Send»). 

Полезной может оказаться в работе и еще

одна функция утилиты — «Hot List» («View ->

Hot List»). Она представляет собой табличку

с 20 ячейками, которую нам предлагается за-

полнить важнейшими текстовыми блоками,

например адресами, часто используемыми

номерами телефонов и web-ссылками. 

В остальном же установки, принятые в

программе по умолчанию, мне показались не

слишком комфортными для пользователя. Я

кое-что позволил себе перестроить в них

(«File -> Preferences»), добавив галочки на-

против строчек «Activate on startup» (чтобы

сразу можно было использовать последний

сохраненный элемент), Minimize on startup

(чтобы программа запускалась только в виде

значка в трее) и «Save clip set on exit» (что-

бы автоматически сохранялась коллекция

при закрытии сlipboard-менеджера).

Clip Plus 2.57
èãûëõ/åàçìëõ

+ Û‰Ó·Ì˚È ÔÓÒÏÓÚ ÒÓı‡ÌÂÌÌ˚ı ˝ÎÂÏÂÌÚÓ‚

+ ËÒÔÓÎ¸ÁÓ‚‡ÌËÂ Hot List ‰Îfl ‡·ÓÚ˚ Ò ˜‡ÒÚÓ

ËÒÔÓÎ¸ÁÛÂÏÓÈ ËÌÙÓÏ‡ˆËÂÈ

– ÌÂÚ ‡Á„‡ÌË˜ÂÌËfl ‚ ÒÔËÒÍÂ ÏÂÊ‰Û „‡ÙËÍÓÈ Ë

ÚÂÍÒÚÓÏ

Clip Plus 2.57
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éÔÂ‡ˆËÓÌÌ‡fl ÒËÒÚÂÏ‡ 3 Windows

ìÒÎÓ‚Ëfl ‡ÒÔÓÒÚ‡ÌÂÌËfl 3 shareware
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Практически все, что по определению может

и должен делать менеджер Буфера обмена,

уже давным-давно имеется на вооружении у

программы американской фирмы Thornsoft

— ClipMate. Но разработчики не останавли-

ваются на достигнутом и чуть ли не каждый

месяц выкладывают на своем сайте очеред-

ную версию с новыми функциями. Так, в по-

следнем релизе 5.3, к примеру, появился

спел-чекер, правда, пока только для амери-

канского английского. Нам это, может быть,

и ни к чему, а вот американцам в самый раз.

Для отечественных пользователей гораздо

полезнее другое новшество ClipMate — ав-

томатически выделяемые в тексте ги-

перссылки, позволяющие одним щелчком

мыши прямо из окна менеджера запускать

браузер, почтовый клиент или закачку.

Однако подлинную славу принесли

продукту Thornsoft совсем другие его воз-

можности. Помимо непосредственно сохра-

нения в укромном месте жесткого диска, Clip-

Mate может склеивать поступившие в Буфер

обмена кусочки текста («Edit -> Glue»). Копи-

руемые элементы можно объединять в кол-

лекции «временные» (Short-Term) и «дол-

гоиграющие» («Long-Term»). Для первой из

них можно задать период хранения или мак-

симальное количество сохраненных элемен-

тов («File -> Collection Properties»). Если хо-

тите, создайте свой личный список («File ->

Add New Collection»). Информация из одной

коллекции в другую перебрасывается легко,

буквально в два клика. А вот внутри них

только в самый верх или низ списка. 

Текст в окне ClipMate можно модифици-

ровать, удалять, набирать заново. Графика

просматривается или в виде уменьшенной

копии, или в натуральную величину. Графи-

ческие элементы склеивать, к сожалению,

нельзя. Разделения между рисунками и тек-

стами в ClipMate нет — все хранятся внутри

общей коллекции. После перезагрузки ком-

пьютера непосредственно в Буфере обмена

оказывается последний скопированный ту-

да элемент, готовый к вставке.

При инсталляции можно задать автома-

тический старт сlipboard-менеджера одно-

временно с загрузкой Windows в системном

трее. Перед первым запуском ClipMate вам

предложат также определить папку для

временного хранения сохраненных в Буфе-

ре обмена текста и графики.

ClipMate 5.3
èãûëõ/åàçìëõ

+ ÌÂÒÍÓÎ¸ÍÓ ÍÓÎÎÂÍˆËÈ ‰Îfl ı‡ÌÂÌËfl

ËÌÙÓÏ‡ˆËË

+ Û‰Ó·Ì˚È ËÌÚÂÙÂÈÒ

+ ‚ÓÁÏÓÊÌÓÒÚ¸ ÒÍÎÂË‚‡ÌËfl ÚÂÍÒÚÓ‚˚ı

Ù‡„ÏÂÌÚÓ‚

– ÌÂÚ ‡Á‰ÂÎÂÌËfl ÔË ı‡ÌÂÌËË ÚÂÍÒÚ‡ Ë „‡ÙËÍË

ClipMate 5.3
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